Sudo on UnixWare 7.1.0 with a shadow-passwd file

Mike Henderson mikeh at
Wed Jul 11 17:25:34 EDT 2001

This is driving me nuts on a 'white box' Intel Pentium server-

A string in the kernel states:
TITLE=UnixWare 7, based on UNIX System V Release 5 from SCO

uname -a
The system is:
UnixWare montoy 5 7.1.0 i386 x86at SCO UNIX_SVR5

The config.sub file implies that UnixWare is 'sysv4', so 'sysv4' and 'sysv5'
has been tried.
includedir and oldincludedir have been tried pointing to /usr/include

types.h is in /usr/include/sys/, /usr/include/rpc/, /usr/ucbinclude/sys/

The man page on getspent says it includes <shadow.h>
getspent is defined in shadow.h in /usr/include/
getspname is defined in shadow.h in /usr/include/
getpwnam is defined in pwd.h in /usr/include/

last configure args:
./configure pentiumpro-intel-sysv4 --with-getpass
--oldincludedir=/usr/include --with-passwd \
	-with-mail-if-noperms -with-insults -with-all-insults
-disable-root-sudo \
	-enable-log-host -with-logfac=local2 -with-passprompt="Password for
%u: "
The '--with-getpass was added after reading the SUPPORTED PLATFORMS note.

And everything still gets me the following in the config.log file:
configure:2590: checking host system type
configure:4076: checking for getspnam
configure:4104: cc -o conftest -g   conftest.c  1>&5
Undefined                       first referenced
 symbol                             in file
getspnam                            conftest.o
UX:ld: ERROR: conftest: fatal error: Symbol referencing errors. No output
written to conftest
configure: failed program was:
#line 4081 "configure"
#include "confdefs.h"
Note 345 of the sudo CHANGE LOG says the shadow passwd detection was fixed
in release 1.5.9 and I am installing 1.6.3p7.
Not being a 'c' programmer, please help me define the proper paths.

Ignorant in Dallas.

Mike Henderson | Unix Administrator | Monitronics International, Inc
    Email: MikeH at | Phone:  800.232.1490  X3065 |  Fax

More information about the sudo-users mailing list