SUDO on UnixWare

Mike Henderson mik3hflash at
Thu Oct 4 15:54:25 EDT 2001

Looks like you've got the same issue I still have - It can't figure out the 
shadow-password file, although I believe it DOES read it.
My submission (cleaned up):
This is driving me nuts on a 'white box' Intel Pentium server-

A string in the kernel states:
TITLE=UnixWare 7, based on UNIX System V Release 5 from SCO

uname -a
The system is:
UnixWare montoy 5 7.1.0 i386 x86at SCO UNIX_SVR5

The config.sub file implies that UnixWare is 'sysv4', so 'sysv4' and 'sysv5' 
have both been tried.
includedir and oldincludedir have been tried pointing to /usr/include 'just 
in case'

types.h is in /usr/include/sys/, /usr/include/rpc/, /usr/ucbinclude/sys/

The man page on getspent says it includes <shadow.h>
getspent is defined in shadow.h in /usr/include/
getspname is defined in shadow.h in /usr/include/
getpwnam is defined in pwd.h in /usr/include/

last configure args:
./configure pentiumpro-intel-sysv4 --with-getpass
--oldincludedir=/usr/include --with-passwd \
	-with-mail-if-noperms -with-insults -with-all-insults
-disable-root-sudo \
	-enable-log-host -with-logfac=local2 -with-passprompt="Password for %u: "
The '--with-getpass' was added after reading the SUPPORTED PLATFORMS note.

And everything still gets me the following in the config.log file:
configure:2590: checking host system type
configure:4076: checking for getspnam
configure:4104: cc -o conftest -g   conftest.c  1>&5
Undefined                       first referenced
symbol                             in file
getspnam                            conftest.o
UX:ld: ERROR: conftest: fatal error: Symbol referencing errors. No output
written to conftest
configure: failed program was:
#line 4081 "configure"
#include "confdefs.h"
Note 345 of the sudo CHANGE LOG says the shadow passwd detection was fixed 
in release 1.5.9 and I am installing 1.6.3p7.
Not being a 'c' programmer, please help me define the proper paths.

Ignorant in Dallas.
MikeH at
- * - * - * - * - * - * - * - * - * - * - *
PS - What does a 'uname -a' show on your system?

Today's Topics:

    1. Sudo on Unixware 2.1.2 (Jason Holland)


Message: 1
Date: Thu, 4 Oct 2001 11:27:17 -0500 (CDT)
From: Jason Holland <jholland at>
To: <sudo-users at>
Subject: Sudo on Unixware 2.1.2

hello all,
   maybe someone can offer some help with my problem.  i have compiled sudo 
1.6.3-p7 on a unixware 2.1.2 box.  compiled and installed without any 
errors.  i used the --with-getpass and --with-passwd options only.
however, when i try and sudo -s to grab a shell, it fails to authenticate me 
correctly, my password never works, no matter which user i try and sudo 
from.  i know the passwords are correct, so i must have missed something 
during the sudo compile.  anyone have any suggestions or ideas??  i don't 
know much about unixware, so troubleshooting this could take me a while 
without help from you guys.  thanks!


ps - could you cc me in the reply, i'm not subscribed to the list, thanks

End of sudo-users Digest

Get your FREE download of MSN Explorer at

More information about the sudo-users mailing list