hpux ia64 shadow fails

Galen Johnson Galen.Johnson at sas.com
Thu Aug 21 18:56:23 EDT 2003

Here's the output of ldd on the lib in question:

ldd -d /usr/local/lib/perl5/5.8.0/IA64.ARCHREV_0/auto/Compress/Zlib/Zlib.so
        symbol not found: PL_sv_yes     (/usr/local/lib/perl5/5.8.0/IA64.ARCHREV_0/auto/Compress/Zlib/Zlib.so)
        symbol not found: PL_tainting   (/usr/local/lib/perl5/5.8.0/IA64.ARCHREV_0/auto/Compress/Zlib/Zlib.so)
        symbol not found: errno (/usr/local/lib/perl5/5.8.0/IA64.ARCHREV_0/auto/Compress/Zlib/Zlib.so)
        symbol not found: PL_curpad     (/usr/local/lib/perl5/5.8.0/IA64.ARCHREV_0/auto/Compress/Zlib/Zlib.so)
        symbol not found: PL_curcop     (/usr/local/lib/perl5/5.8.0/IA64.ARCHREV_0/auto/Compress/Zlib/Zlib.so)
        symbol not found: PL_op (/usr/local/lib/perl5/5.8.0/IA64.ARCHREV_0/auto/Compress/Zlib/Zlib.so)
        symbol not found: PL_stack_sp   (/usr/local/lib/perl5/5.8.0/IA64.ARCHREV_0/auto/Compress/Zlib/Zlib.so)
        symbol not found: PL_compiling  (/usr/local/lib/perl5/5.8.0/IA64.ARCHREV_0/auto/Compress/Zlib/Zlib.so)
        symbol not found: PL_tainted    (/usr/local/lib/perl5/5.8.0/IA64.ARCHREV_0/auto/Compress/Zlib/Zlib.so)
        symbol not found: PL_markstack_ptr      (/usr/local/lib/perl5/5.8.0/IA64.ARCHREV_0/auto/Compress/Zlib/Zlib.so)
        symbol not found: PL_stack_base (/usr/local/lib/perl5/5.8.0/IA64.ARCHREV_0/auto/Compress/Zlib/Zlib.so)
        symbol not found: PL_stack_max  (/usr/local/lib/perl5/5.8.0/IA64.ARCHREV_0/auto/Compress/Zlib/Zlib.so)
        symbol not found: PL_sv_undef   (/usr/local/lib/perl5/5.8.0/IA64.ARCHREV_0/auto/Compress/Zlib/Zlib.so)

It makes me think that I'm missing a library but I've grabbed them all.


-----Original Message-----
From: Galen Johnson [mailto:Galen.Johnson at sas.com] 
Sent: Thursday, August 21, 2003 6:45 PM
To: sudo-users at sudo.ws
Subject: hpux ia64 shadow fails


  I've tried every configuration I can think.  I've tried every option for shadow access in the config.h file and I've tried both gcc and hpux's native compiler...nothing helps.

I'm running on an HP 2600rx system with hpux 11.22 ipf.  I've tried the following config option:
./configure --prefix=/usr/local --enable-shadow --without-pam

After installing the files I try to run sudo but it tells me my password is incorrect.  If I place the password in /etc/passwd then it works...I've read the FAQ and tried every define option but nothing has worked thusfar.

Anyone have any other ideas? (I'm rapidly beginning to dislike hpux)


Galen Johnson; SCSA, CCNA 
Systems Administrator
ASP Market Development 

sudo-users mailing list <sudo-users at sudo.ws>
For list information, options, or to unsubscribe, visit:

More information about the sudo-users mailing list