[sudo-users] sudoers doesnt work

Ultrakorne ultrakorne at paranoici.org
Thu Dec 30 10:02:24 EST 2004

i am running ubuntu warty, so some lines in sudoers are made by ubuntu
installer (as you know root is disabled by default and the first user
have sudo powers to execute all as root )
i want simply to run ls (for example) as ROOT without password this is
my sudoers, and the problem is the system is still asking me the
password when i run 'sudo ls'. i want to run it withous password!

# sudoers file.
# This file MUST be edited with the 'visudo' command as root.
# See the man page for details on how to write a sudoers file.

# Host alias specification

# User alias specification

# Cmnd alias specification

# Defaults

Defaults !lecture,tty_tickets

ultra ALL= (root) NOPASSWD: /bin/ls

# User privilege specification
root  ALL=(ALL) ALL

# Added by Ubuntu installer
ultra ALL=(ALL) ALL

if i run sudo ls, the system ask me for the password
on auth.log, when i run 'sudo ls' and ctrl-c the passwd

Dec 30 04:28:06 localhost sudo: (pam_unix) authentication failure;
logname=ultra uid=0 euid=0 tty=pts/3 ruser= rhost=  user=ultra

if i write the wrong pass

Dec 30 04:46:36 localhost sudo:    ultra : 3 incorrect password attempts
; TTY=pts/3 ; PWD=/home/ultra ; USER=root ; COMMAND=/bin/ls

but, i set NOPASSWD why still sudo ask me for the pass ? whats wrong

ultra ALL= NOPASSWD: /bin/ls
ALL localhost= NOPASSWD: /bin/ls

but the syntax is corret, is useless try to change those details...

this is drive me mad

i edited with visudo... but something is corrupted? what can i try
i asked on ubuntu ml , but noone could help me. thx all by

More information about the sudo-users mailing list