[sudo-users] Sudo on Solaris 10 AMD64

Allen Hewes allen at decisiv.net
Mon Nov 7 15:27:27 EST 2005


I am getting a odd error with sudo 1.6.8p9. I am on Solaris 10 x86 with
the latest patches. Its an AMD64 Opteron. I ran configure with:
--prefix=/usr/local/packages/sudo --with-pam --with-insults
--with-all-insults --disable-root-sudo

Output of cc -V: cc Sun C 5.7 2005/01/07
CFLAGS are -xtarget=opteron -xarch=amd64
LDFLAGS are -M /usr/lib/ld/map.noexstk -xtarget=opteron -xarch=amd64

When I run sudo I get sudo: pam_authenticate: Dlopen failure.
Pam_authenticate is being called from auth/pam.c. I get this error in

sudo[715]: [ID 401707 auth.error] open_module:
/usr/lib/security/64/pam_authtok_get.so.1 failed: ld.so.1: sudo: fatal:
libsoftokn3.so: open failed: No such file or directory

Output of ldd /usr/lib/security/64/pam_authtok_get.so.1
passwdutil.so.1 =>       /usr/lib/64/passwdutil.so.1
libpam.so.1 =>   /lib/64/libpam.so.1
libc.so.1 =>     /lib/64/libc.so.1
libcmd.so.1 =>   /lib/64/libcmd.so.1
libsldap.so.1 =>         /usr/lib/64/libsldap.so.1
libnsl.so.1 =>   /lib/64/libnsl.so.1
libldap.so.5 =>  /usr/lib/64/libldap.so.5
libdoor.so.1 =>  /lib/64/libdoor.so.1
libmp.so.2 =>    /lib/64/libmp.so.2
libmd5.so.1 =>   /lib/64/libmd5.so.1
libscf.so.1 =>   /lib/64/libscf.so.1
libsasl.so.1 =>  /usr/lib/64/libsasl.so.1
libsocket.so.1 =>        /lib/64/libsocket.so.1
libnspr4.so =>   /usr/lib/mps/64/libnspr4.so
libplc4.so =>    /usr/lib/mps/64/libplc4.so
libnss3.so =>    /usr/lib/mps/64/libnss3.so
libssl3.so =>    /usr/lib/mps/64/libssl3.so
libuutil.so.1 =>         /lib/64/libuutil.so.1
libpthread.so.1 =>       /lib/64/libpthread.so.1
libthread.so.1 =>        /lib/64/libthread.so.1
librt.so.1 =>    /lib/64/librt.so.1
libdl.so.1 =>    /lib/64/libdl.so.1
libsoftokn3.so =>        /usr/lib/mps/amd64/libsoftokn3.so
libplds4.so =>   /usr/lib/mps/amd64/libplds4.so
libaio.so.1 =>   /lib/64/libaio.so.1
libm.so.2 =>     /lib/64/libm.so.2

Does anyone have any ideas? 


This message contains confidential information and is intended only for
the individual named. If you are not the named addressee you should not
disseminate, distribute or copy this e-mail. Please notify the sender
immediately by e-mail if you have received this e-mail by mistake and
delete this e-mail from your system. 

More information about the sudo-users mailing list