[sudo-users] SUDO does not accept password longer than 8 characters in Trusted Systems

Liu Wallace wliu at woolworths.com.au
Wed Feb 7 04:30:10 EST 2007

Hi Jan,

Your perception is correct. Following Todd's suggestion, I ran configure
--with-pam and solved the problem.

Thanks a lot.


-----Original Message-----
From: jan kalcic [mailto:jandot at googlemail.com] 
Sent: Wednesday, 7 February 2007 1:42 AM
To: Liu Wallace
Cc: sudo-users at sudo.ws
Subject: Re: [sudo-users] SUDO does not accept password longer than 8
characters in Trusted Systems

Liu Wallace wrote:
> Hi Sudo Community,
> I am running sudo-1.6.8p12 on HP-UX11.11 and HP-UX 11.23 which are
> configured to run Trusted System. In Trusted System mode, the
> password is in /tcb/files/auth/* directories. If the user password is
> not longer than 8 characters,  sudo accepts the password. If the
> password is longer than 8 characters, then sudo does not accept it:
> kwlu1 at chinft1-/home/kwlu1> sudo su -

> Password:
> Sorry, try again.
> Password:
Not really know sudo in depth but I wonder if it could be a PAM-related
configuration issue.


CAUTION: This email and files included in its transmission 
are solely intended for the use of the addressee(s) and may 
contain information that is confidential and privileged. 
If you receive this email in error, please advise us 
immediately and delete it without copying the contents 
contained within. Woolworths Limited (including its group 
of companies) do not accept liability for the views 
expressed within or the consequences of any computer 
viruses that may be transmitted with this email. The 
contents are also subject to copyright. No part of it 
should be reproduced, adapted or transmitted without the 
written consent of the copyright owner.

More information about the sudo-users mailing list