[sudo-users] Error trying "make" in Sudo

Tiz sudo at tizatron.com
Wed Dec 17 14:05:53 EST 2008

Todd C. Miller wrote:
> You may be linking against the wrong libintl.  You should be
> able to find which one defines libintl_dgettext by doing something
> like:
> You could try running configure with
>     --with-libpath=/usr/lib --with-incpath=/usr/include
> to try and get gcc to use the system libintl.  By default, gcc will
> prefer includes in /usr/local/include over those in /usr/include
> and libraries in /usr/local/lib over /usr/lib.  This is probably
> what is giving you problems.  If you have the Sun C compiler, you
> could use that instead which doesn't have this brain damaged behavior.
> If that doesn't help, try to find which lib libintl_dgettext
> is in.  E.g.
> /usr/ccs/bin/nm /usr/lib/libintl.so | grep libintl_dgettext
> and
> /usr/ccs/bin/nm /usr/local/lib/libintl.so | grep libintl_dgettext
> I would expect it to be in /usr/local/lib/libintl.so.
>  - todd


Thanks for the information.

Why I did not try my studio12 compiler I do not know.  *sigh*

I was able to get a clean build using...
	configure \
                 --with-editor=vi \
                 --enable-static \

I tried...

/usr/ccs/bin/nm /usr/lib/libintl.so | grep libintl_dgettext


I then tried looking at the lib in /usr/local/lib.  I realized that I mistakenly 
installed the X86 version of the lib.  Bummer.

I removed all the SMC packages and installed only libintl-3.4.0-sol10-sparc-local

/usr/ccs/bin/nm /usr/local/lib/libintl.so | grep libintl_dgettext
[276]   |      9764|      20|FUNC |GLOB |0    |11     |libintl_dgettext

Helps if you install the correct library. :}

I then got a clean build with...

	configure \
                 --with-editor=vi \
                 --enable-static \

Worth noting that I pull my gcc compiler out of an NFS shared 
/opt/csw/gcc4/bin/gcc.  Long story - another time, but points to why I need 
'--with-libpath' since I don't like using LD_LIBRARY_PATH.


/usr/ccs/bin/nm /opt/csw/lib/libintl.so | grep libintl_dgettext

Produces no output.

Also - a note to Russel:

I agree with your take on SMC packages.  I have since removed all the SMC 
packages expat, gettext, etc.  Recompiled with studio12 - no issues.

Sticking with the studio12 compiler.

I also had clean builds on studio11, forte10, forte8 and forte62 with 
sudo.1.6.9p19.  The compile time is short, the compilers were available so I 
thought I would give them a spin...yada yada yada.

Thanks for the help.


More information about the sudo-users mailing list