[sudo-users] sudo -u issue

David Halik dhalik at jla.rutgers.edu
Mon Jun 2 14:54:51 EDT 2008

Hi, I just had a quick question. I've been looking into how to setup 
sudo -u to allow some employees to run scripts as other users. The 
problem is, I thought what I had setup was properly done based off all 
all the docs and discussions I've seen, but I can not get it to 
recognize NOPASSWD. Whenever sudo -u is invoked it prompts me, whereas 
sudo alone does not. Here's an example of what I'm trying to do. Now in 
this example I'm restricting the groups that people can run as, but with 
or without that it does not make a difference, I still get prompted:

Cmnd_Alias SCRIPT = /usr/local/bin/script
Runas_Alias SCRIPT_GROUPS = %11013

root ALL=(ALL) ALL


Running this as myself works fine without a prompt, using -u prompts me 
even though I am in our equivalent of wheel and attached to the root 
group. I thought maybe it had something to do with that fact that I'm 
trying to run as another user, but why considering I can su - or anyone 
else without a password, and if I run the command without -u it works.

Any advice would be appreciated!

David Halik
System Administrator
OIT-CSS Rutgers University
dhalik at jla.rutgers.edu

More information about the sudo-users mailing list