[sudo-users] sudo crontab

Galen Johnson Galen.Johnson at sas.com
Thu Mar 6 14:25:41 EST 2008

You find some other solaris oddities with sudo 1.6.9+ (haven't tried the 1.7 beta branch)...we've seen it strip out LD* variables when you have them in a script...particularly with su:


su someuser -c "env"

This has consistently failed for us (we have a postgres script that barfs every time unless we add the LD* in front of the actual command...su someuser -c "LD_LIBRARY_PATH=${LD_LIBRARY_PATH):/some/new/path env").  This worked fine with 1.6.8 but 1.6.9 seems to have something that causes this.  I just happened to have an environment that had both and the same script was run in both.

This be something unique to our environments (which make heavy use of zones) but it is consistent throughout.


-----Original Message-----
From: sudo-users-bounces at courtesan.com [mailto:sudo-users-bounces at courtesan.com] On Behalf Of Jeanne Ilchuk
Sent: Thursday, March 06, 2008 1:53 PM
To: Todd C. Miller
Cc: sudo-users at courtesan.com
Subject: Re: [sudo-users] sudo crontab

How'd you know I was on Solaris :-)

Thanks, that is working perfectly.  My fingers were wearing out logging
in and out of all app users (such as SFX instances, we have 9).  Thanks


Todd C. Miller wrote:
> Try adding the following line to the top of you sudoers file:
> Defaults      env_keep+=EDITOR
> It looks like Solaris defaults to ed, not vi if EDITOR is not set.
>  - todd

sudo-users mailing list <sudo-users at sudo.ws>
For list information, options, or to unsubscribe, visit:

More information about the sudo-users mailing list