[sudo-users] segfault with v1.7r3

Russell Van Tassell russell+sudo-users at loosenut.com
Mon Nov 10 14:56:22 EST 2008

On Fri, Nov 07, 2008 at 12:02:04PM -0500, Chris O'Regan wrote:
> I am experiencing a problem with sudo v1.7rc3. When I run sudo the first 
> time, it works, but it segfaults if I run again. I can work around the 
> problem by running "sudo -k" or waiting until my timestamp expires.
> What's strange is that I can reproduce the problem on some systems, but 
> not on others (all are pretty much identical, running RHEL3 with the 
> same patches and configuration). I do not experience the problem if I 
> have logged into my account from root via "su" ("su chris", no "-", does 
> not work with "su - chris"). I've also tested with the v1.7rc2 binary 
> and it is fine, too.
> Any ideas?

It would *sound* like there's something in your startup scripts under
the "chris" account (but not under root) that's causing the issue...
what happens if you move them out of the way?

Of course, it shouldn't segfault, period... but that might give you
something to go on... Todd (or someone else) might have more ideas,

Russell M. Van Tassell
russell at loosenut.com

"He has no enemies, but is intensely disliked by his friends." - Oscar

More information about the sudo-users mailing list