[sudo-users] Always parse error (except for empty sudoers)

josef schmid e9427749 at stud4.tuwien.ac.at
Mon Jun 29 14:55:59 EDT 2009

Todd C. Miller schrieb:
> In message <4A43B4C2.5010606 at stud4.tuwien.ac.at>
> 	so spake josef schmid (e9427749):
>> I have tried both, same result.
>> (With --with-devel additionally i get some compiler warnings.)
>> First try was without.
>> Maybe some other dependencies? Needed Libraries which are defective? […]
> Can you try using the system compiler and see if that changes anything?
> E.g. give configure --with-CC=cc

After i read the 'Dynix' section, this was on my todo list anyway.
But no success. :-(

CC=cc; CFLAFS=-Ae; export CC CFLAGS
./configure … --with-CC=cc --with(out)-noexec

Beside a problem with the HP ANSI Compiler (a non patched error)¹.
It doesn't allow the building of noexec (No support of -b in cc
directly, and with -Wl,-b the linker use the wrong crt0.o file).

I get the same results.
(Normally gcc works more often.)

I can look at the source from the porting archive, maybe this guys
have something hacked around. But the chances are not high.
(On the other side, if the use -DAportable, hmm, so two things
  left what i can try².)

Maybe more error checks in sudo are helpful, than hopefully
i get more information than that parsing fail.
(I'm so shameless to ask for this. ;-)

Something completely different:
   Some features i find nice:
   * If sudo resolve aliases late, than i think it is easier to build
     complex setup. E.g.:

     User_Alias DJANGO myacount

     Defaults:myaccount some_options
     Defaults:DJANGO    some_other_options
     # instead of resolving DJANGO here,
     # the options are stored for the alias

     DJANGO HOST = cmd1
     # uses some_other_options for cmd1
     myaccount HOST = cmd2
     # uses some_options
     # of course, for this example '!' can be used now³.

   * Allow combination ala:
     Defaults:DJANGO>root!CMDXS some_options_for_a_very_specific_case

thanx for your help so far & for sudo,
   Jos "excuse for my bad english" ef

ad 1) It seems: Instead of the availability of a patch,
                 a new version can be purchased.
       Maybe ld /opt/langtools/lib/scrt0.o -b +h sudo_noexec.sl +b \
      /usr/…/libexec -o .libs/sudo_noexec.sl .libs/sudo_noexec.o -lc
      works, (without -DAportable). But not with the help of cc -Wl!
ad 2) But not today.
ad 3) Not for me, at the moment ;-(

More information about the sudo-users mailing list