[sudo-users] cannot sudo after short time - ldap/nis configuration

Tony G. tonysk8 at gmx.net
Wed Oct 21 12:19:10 EDT 2009

Have you tried to login and run sudo with nscd turned off? nscd can be a
nightmare or can be really helpful, try to verify it working without ncsd

Do you have sudoers in nsswitch.conf?

On Tue, Oct 20, 2009 at 9:07 AM, Jason Hamilton <jason at meanasspenguin.org>wrote:

> Hi all,
> I've not been very successful finding a fix for this on google, so any
> help is appreciated.
> Running centos 5, with sudo "sudo-1.6.9p17-3.el5_3.1". The system is
> configured with ldap/nis and sudoers_base is also configured through
> LDAP. Everything works great upon initial login, I can 'sudo' whatever
> and it works - then a little while later - maybe 5 minutes, I get:
> me at foo:[12:03:36 PM]~$ sudo ls
> sudo: uid 1000 does not exist in the passwd file!
> me at foo:[12:04:25 PM]~$
> now, if I run "getent passwd me"
> the system looks at ldap, and gives me the user data and then sudo works
> again.
> I'm running nscd on the system and it appears to be working properly. Is
> there something that I'm missing? I don't really want to run 'getent' in
> a cron or some other hinky workaround.
> Thanks for any tips.
> --
> -Jason
> ____________________________________________________________
> sudo-users mailing list <sudo-users at sudo.ws>
> For list information, options, or to unsubscribe, visit:
> http://www.sudo.ws/mailman/listinfo/sudo-users


More information about the sudo-users mailing list