[sudo-users] sudo never prompts for password

Donald Jenkins dj.jankins at gmail.com
Sat Nov 27 14:18:58 EST 2010

On 11/26/10, Todd C. Miller <Todd.Miller at courtesan.com> wrote:
> Some vendors build sudo with the exempt_group feature enabled by
> default.  Try running the this on one of the affected servers:
> $ sudo sudo -V | grep exempt
> If you see something like:
> Users in this group are exempt from password and PATH requirements: sudo
> then that sudo binary has been compiled such that users in the
> "sudo" group need not enter a password.
> You can disable that by adding the following line to sudoers file.
>     Defaults !exempt_group
>  - todd
Hello. I have solved problem now, PAM for sudo was not properly configured.
I looked in both configs on desktop and server and saw that they are different,
one on server lacked pam_unix.so for auth and account. sudo PAM file
was bare su clone. Now problem is solved, thanks for your reply.

More information about the sudo-users mailing list