[sudo-users] Upgrade issue

Keshava Murthy keshavamv at gmail.com
Thu May 26 16:28:44 EDT 2011

Thanks Todd. That worked. After the install I had to add
/usr/local/sbin and /usr/local/bin to PATH in  /etc/environment. Is
there an option I can specify during the upgrade so as to retain these

Also, if I run a  upgrade the /etc/sudoers file doesn't reflect the
fields for 1.7.4 version. It just retains the old sudoers file from
the old version. Is there any upgrade option I can use so that the old
configurations gets transfered over to the new sudoers file.

- Keshava

On Thu, May 26, 2011 at 9:47 AM, Todd C. Miller
<Todd.Miller at courtesan.com> wrote:
> On Thu, 26 May 2011 09:38:45 CDT, Keshava Murthy wrote:
>> I am trying to upgrade sudo on AIX from Sudo version 1.6.7p5 to
>> 1.7.4p6. When I run the upgrade I am getting below message which
>> doesn't make sense to me as it is giving  a message 1.6.7 is newer
>> than 1.7.4. Could anyone  explain what might happening here?
> rpm gets confused by the patchlevel in the version number.
> If you pass rpm the --oldpackage flag it should install it.
>  - todd

More information about the sudo-users mailing list