[sudo-users] Unprivledged user isn't able to reboot system via sudo

Simon K k_simon78 at yahoo.com
Mon Jul 30 08:54:30 EDT 2012

Hi All ,

Please ignore my previous mail .

I compiled Sudo version 1.7.9 on HPUX machine , but when i tried to run below command as a sudo user it is not working properly.

Machine Details :

OS : HPUX  11.31 IA
HW : Virtual Machine
Command : shutdown  -r  now 

The user and command both have been added in sudoers file , but still it is not able to reboot , shutdown command is working but "shutdown -r now" is not working .

I tried below mentioned scenarios but neither of them is working.

1 . Reboot on console :

When I reboot the system on the console as unprivileged  user by typing:
# sudo /sbin/shutdown -r now
System is run to all stop scripts , Stopping at shell prompt and
Now I will have to switch user to root and will have to reboot again

2.Reboot shell :

Similar behavior, but:
->I loose the network connection  
->If I try to logon  through the console, it isn't possible anymore (this is different to the 1st scenario)

Please suggest how to proceed .. Waiting for the response.

Thanks & Regards,
Simon K

More information about the sudo-users mailing list