No subject

Fri Sep 28 08:36:56 EDT 2012

First I run some trivial command with sudo, so that sudo will ask for
(and then remember) my password:

   sudo ls

Next I run dxaccounts:

   sudo dxaccounts -display myworkstation:0.0 &

and voila! Up it comes on my workstation.

If I omit the first step, ie, if sudo wants my password 
for the dxaccounts command, it bombs out.

The sudo man page will tell you how to run sudo with some option 
so that it will simply ask for a password and nothing more. I think
it's 'sudo -v' and I have done something like this in the past:

  echo "Please enter your normal password here"
  sudo -v
  sudo dxaccounts
  # For remote display, extend this script by asking for display host and
  # sudo dxaccounts -display hostname:0.0

Thanks also to George Meharry II for his prompt response.

	-Joan Riggs

-----Original Message-----
From: Riggs, Joan [mailto:JRiggs at]

I am configuring sudo on a Digital Unix system and want my help desk to 
be able to use the  dxaccounts GUI via sudo - but I can't get it working!  
what is the trick with X11 windows?

	thanks in advance,

Joan Riggs
Raytheon RSE / KLS 
Information Technology
805.355.9877 [ +12 GMT ] 
joan.riggs at

More information about the sudo-users mailing list