[sudo-users] Sudo: parse error in /etc/sudoers near line -1

Eugene J. Pate Eugene.Pate at panduit.com
Thu Jun 11 14:21:58 MDT 2015

THANKS Todd, that worked and the upgrade resolved by parse problem!


-----Original Message-----
From: Todd C. Miller [mailto:Todd.Miller at courtesan.com] 
Sent: Thursday, June 11, 2015 11:39 AM
To: Eugene J. Pate
Cc: Greg Gerke; sudo-users at sudo.ws
Subject: Re: [sudo-users] Sudo: parse error in /etc/sudoers near line -1

On Thu, 11 Jun 2015 16:15:23 -0000, "Eugene J. Pate" wrote:

> I also tried to upgrade to sudo-1.7.0-1.aix6.1.ppc.rpm and received 
> pretty much the same msg, any suggestions would be greatly appreciated.
> EXP:
> # rpm -Uvh sudo-1.7.0-1.aix6.1.ppc.rpm package sudo-1.6.9p15-2 (which 
> is newer than sudo-1.7.0-1) is already installed

I wouldn't suggest running sudo 1.7.0 due to its age, but you can avoid the rpm error by using the --oldpackage option.  I suspect rpm is just confused by the version number.

 - todd

More information about the sudo-users mailing list