[sudo-users] help with HPUX

Serbec Robar Irena Irena.SerbecRobar at bankart.si
Mon Apr 8 03:47:01 MDT 2019


We use sudo on HPUX servers for years now.

We mostly use it in a background inside scripts which are executed by users who execute »ssh script« from remote servers (using keys).
It worked just fine with settings »!requiretty, !pam_session« for versions up to  1.8.20p.

Higher versions of sudo return »PAM account management error: General Commercial Security error«

As we already explicity require no pam_session, I'm at lost what to do.

It works fine if you trigger ssh with »-t« option,
But as users are not from our company, it is hard to request change from all of them.

Please, advise.

We are testing RADIUS logins and I noticed that if we use sudo, after successfully entering domain password
»count of unsuccesfull logins« is increased by 1 (should be reset).
I've seen that in higher versions of sudo you solved some issues with wtmp, so that might be already solved.

Thanks in advance for your help.

Irena Šerbec Robar

More information about the sudo-users mailing list