[sudo-workers] Problems building sudo-1.6.8p12 on RHEL3u7

Avram Lubkin avraml at yahoo.com
Sat Sep 1 00:08:21 EDT 2007

I know it's been a while since you brought this issue up, but I had the same problem rolling sudo on RHEL 3. I was finally able to get it to work.

I started with the spec file from redhat's source rpm for sudo 1.6.8p12-10.
After changing the obvious (version, patches), I had to make 4 changes:

Remove LDFLAGS="-pie" from the export line
    -This took care of the compiling errors
    - I also removed $F_PIE (-fpie) from the CFLAGS, even though it still work with it, because these two go together as far as I know

Fixed PAM sudo and sudo-i files
    - I made them the same as the original. include isn't supported on that version of PAM and pam_keyinit.so isn't on the system

Removed RUNSON from %doc
    - Looks like it's not included in the latest source
    - Put README.LDAP in it's place

Commented out %{_libexecdir}/sudo_noexec.* in the %files section
    - It didn't seem to find anything there and would error out

It seems to work well with 1.6.8p12 as well as 1.6.9p4, but I'm a little concerned about something hiding. Any idea what the impact of removing the LDFLAGS is? And should I be concerned that there's nothing at %{_libexecdir}/sudo_noexec.*?


-----Original Message-----Hi Todd and thanks for the quick response!

It's a bit weird but ./configure seems to only fail (as in get the
closefrom answer wrong, btw it also gets getprogname, strlcpy and
strlcat wrong) when run via rpmbuild (still not sure why)...

Once I had manually build and installed sudo I also had to change the
PAM sudo file to work with our setup:
auth     required pam_stack.so service=system-auth
account  required pam_stack.so service=system-auth
password required pam_stack.so service=system-auth
session  required pam_limits.so
As I said before, this is RHEL 3u7 (same result in u8 BETA).  This
version uses PAM 0.75-67.

I'll have another look at the RPM .spec file...

Thanks again.


-----Original Message-----
From: Todd C. Miller [mailto:Todd.Miller at courtesan.com] 
Sent: Monday, 17 July 2006 8:20 PM
To: Coe, Colin C.
Cc: sudo-workers at sudo.ws
Subject: Re: [sudo-workers] Problems building sudo-1.6.8p12 on RHEL3u7
(undefined reference to `closefrom') 

Can you try adding closefrom.o to LIBOBJS in the generated Makefile?
I don't know why configure wouldn't be doing the right thing.

 - todd

____________________________________________________________________________________Ready for the edge of your seat? 
Check out tonight's top picks on Yahoo! TV. 

More information about the sudo-workers mailing list