[sudo-users] Using wild cards in a command path

christian.peper at kpn.com christian.peper at kpn.com
Wed Jul 30 03:25:09 EDT 2008


Assuming you've tried to check sudo -l to get a list of allowed cmnds...
when you run the command, do you type its full path matching the path in
sudoers, or do you just give the command name using your $PATH to fetch
the path to the command?

That may be why sudoers thinks it doesn't match the specification...
Although that would be weird.


> -----Original Message-----
> From: sudo-users-bounces at courtesan.com 
> [mailto:sudo-users-bounces at courtesan.com] On Behalf Of Eric Bradley
> Sent: Tuesday, July 29, 2008 3:47 PM
> To: Russell Van Tassell
> Cc: Carville, Stephen; sudo-users at sudo.ws
> Subject: Re: [sudo-users] Using wild cards in a command path
> I've tried that and it returns the correct thing
> (root) NOPASSWD: /opt/networker/bin/*     which doesn't work 
> - get user is 
> not allowed to execute the command as root
> If I change the sudoers file to /opt/networker/bin/tempo.sh I 
> can run tempo.sh as root just fine. So the absolute path 
> including the name of the command at the end works, but the 

More information about the sudo-users mailing list