[sudo-users] Always parse error (except for empty sudoers)

josef schmid e9427749 at stud4.tuwien.ac.at
Thu Jun 25 13:32:50 EDT 2009

Todd C. Miller schrieb:
> In message <4A4299F8.8090508 at stud4.tuwien.ac.at>
> 	so spake josef schmid (e9427749):
>> After compiling sudo (v1.7.1 & also v1.7.2b3 tested)
>> sudo and visudo -scf <file> always results in a
>> syntax/parse error.
>> This problem occur for:
>> a) the sudoers file in the package      (=> line 3)
>> b) with only the following line as content: root    ALL=(ALL) ALL
>>                                          (=> line 0)
>> c) For a file with only comments        (=> line 3 if more than 3lines)
>> d) for everything else, except empty file
>> For HP-UX B.11.00, gcc v3.0.4, Flex v2.5.4, bison v1.875)
> Are you using the pre-generated parser that comes with sudo or are
> you regenerating it with your own bison and flex?  Unless you passed
> configure --with-devel sudo will use the prebuild parser which
> should work fine.  I've run into problems with different versions
> of flex on some systems, resulting in behavior like what you report
> above.

I have tried both, same result.
(With --with-devel additionally i get some compiler warnings.)
First try was without.

Maybe some other dependencies? Needed Libraries which are defective?

configure search for sed, and the hp-ux version is a little strange.
For what is sed needed? Make it sense retry this with gnu sed?

What else can i try?

$ make clean # or make distclean + reextracting def_data.[ch],toke.c,…
$ ./configure --prefix=… --sysconfdir=/etc/sudo \
             --with-passwd --with-noexec \
             --with-env-editor --with-sudoers-gid=3 \
$ make
$ ./visudo …

Trying this also with different CFLAGS ala
(-D… affect compatibly macros in the std include files on the hp-ux).

   Jo "glueless" sef

(BTW. Maybe nice to have: --allowed-sudoers-gids=0,3

More information about the sudo-users mailing list