[sudo-users] How userA can run userB's script

Erwin Hom erwin_hom at filemaker.com
Mon May 4 22:05:51 EDT 2009

HI Russell,

I ran it "sudo -l" under usera.

Got prompted for a password. Entered the root password and
got the following output:

"bash-3.2$ sudo -l
Sorry, user usera may not run sudo on 146x102."

Is there something to be added to sudoers that will allow usera to run  


- Erwin

On May 4, 2009, at 6:27 PM, Russell Van Tassell wrote:

> What's the output of "sudo -l" for usera?  Chances are they're not
> allowed to execute the script you've created...
> On Mon, May 04, 2009 at 05:07:13PM -0700, Erwin Hom wrote:
>> Hi Todd,
>> I tried your recommendation but couldn't get it to work.
>>  commandLine: "sudo -u userb userbscript.sh"
>> I entered userb's password when prompted.
>> This is the message that sudo displayed:
>> "usera is not in the sudoers file. This incident will be reported."
>> What did I do wrong? Did I miss a step along the way?
>> - Erwin
> -- 
> Russell M. Van Tassell
> russell at loosenut.com
> I've come up with a set of rules that describe our reactions to  
> technologies:
> 1. Anything that is in the world when you're born is normal and  
> ordinary
>   and is just a natural part of the way the world works.
> 2. Anything that's invented between when you're fifteen and thirty- 
> five
>   is new and exciting and revolutionary and you can probably get a  
> career
>   in it.
> 3. Anything invented after you're thirty-five is against the natural
>   order of things.
>               - Douglas Adams (1952 - 2001), The Salmon of Doubt, p.  
> 95

More information about the sudo-users mailing list