[sudo-workers] sudo 1.8.0 and lib_pam

Thomas, Matthew (GE Tech Infra, US) matthewt.thomas at ge.com
Wed Mar 16 17:03:04 EDT 2011


I encountered a small issue with building sudo 1.8.0. on Solaris x86 with
the options "-with-ldap -with-pam". When running sudo I would recieve a
library error:


symbol pam_get_item: referenced symbol not found


This appears to only happen when I have a specific add-on pam module
installed, but earlier versions of sudo compile and work just fine with this
pam module.


Comparing the 1.8.0 and 1.7.x  versions of sudo which worked, I noticed that
the old version of sudo was linked against libpam, while 1.8.0 was not. I
was able to resolve the issue by adding "-with-libraries=-lpam" to the
configure options.


Checking the makefile when I run configure -with-ldap -with-pam I notice:


# grep -- -lpam src/Makefile



When I specify the -with-libraries=-lpam I see:

# grep -- -lpam src/Makefile 

LIBS =  -lpam -lintl    -lsocket -lnsl $(LT_LIBS)



It looks like it ignored both the -with-ldap and -with-pam. 


Checking the Makefiles, SUDOERS_LIBS variable was added into the
plugins/sudoers/Makefile, not the src/Makefile.  The SUDOERS_LIBS  probably
needs to be added to src/Makefile as well.




More information about the sudo-workers mailing list